IANA-RTPROTO-MIB.txt 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103
  1. IANA-RTPROTO-MIB DEFINITIONS ::= BEGIN
  2. IMPORTS
  3. MODULE-IDENTITY, mib-2 FROM SNMPv2-SMI
  4. TEXTUAL-CONVENTION FROM SNMPv2-TC;
  5. ianaRtProtoMIB MODULE-IDENTITY
  6. LAST-UPDATED "201604250000Z" -- April 25, 2016
  7. ORGANIZATION "IANA"
  8. CONTACT-INFO
  9. " Internet Assigned Numbers Authority
  10. Internet Corporation for Assigned Names and Numbers
  11. 12025 Waterfront Drive, Suite 300
  12. Los Angeles, CA 90094-2536
  13. Phone: +1 310 301 5800
  14. EMail: iana&iana.org"
  15. DESCRIPTION
  16. "This MIB module defines the IANAipRouteProtocol and
  17. IANAipMRouteProtocol textual conventions for use in MIBs
  18. which need to identify unicast or multicast routing
  19. mechanisms.
  20. Any additions or changes to the contents of this MIB module
  21. require either publication of an RFC, or Designated Expert
  22. Review as defined in RFC 2434, Guidelines for Writing an
  23. IANA Considerations Section in RFCs. The Designated Expert
  24. will be selected by the IESG Area Director(s) of the Routing
  25. Area."
  26. REVISION "201604250000Z" -- April 25, 2016
  27. DESCRIPTION "Corrected typographical error in revision date."
  28. REVISION "201604060000Z" -- April 6, 2016
  29. DESCRIPTION "Added ttdp(20)."
  30. REVISION "201208300000Z" -- August 30, 2012
  31. DESCRIPTION "Added dhcp(19)."
  32. REVISION "201107220000Z" -- July 22, 2011
  33. DESCRIPTION "Added rpl(18) ."
  34. REVISION "200009260000Z" -- September 26, 2000
  35. DESCRIPTION "Original version, published in coordination
  36. with RFC 2932."
  37. ::= { mib-2 84 }
  38. IANAipRouteProtocol ::= TEXTUAL-CONVENTION
  39. STATUS current
  40. DESCRIPTION
  41. "A mechanism for learning routes. Inclusion of values for
  42. routing protocols is not intended to imply that those
  43. protocols need be supported."
  44. SYNTAX INTEGER {
  45. other (1), -- not specified
  46. local (2), -- local interface
  47. netmgmt (3), -- static route
  48. icmp (4), -- result of ICMP Redirect
  49. -- the following are all dynamic
  50. -- routing protocols
  51. egp (5), -- Exterior Gateway Protocol
  52. ggp (6), -- Gateway-Gateway Protocol
  53. hello (7), -- FuzzBall HelloSpeak
  54. rip (8), -- Berkeley RIP or RIP-II
  55. isIs (9), -- Dual IS-IS
  56. esIs (10), -- ISO 9542
  57. ciscoIgrp (11), -- Cisco IGRP
  58. bbnSpfIgp (12), -- BBN SPF IGP
  59. ospf (13), -- Open Shortest Path First
  60. bgp (14), -- Border Gateway Protocol
  61. idpr (15), -- InterDomain Policy Routing
  62. ciscoEigrp (16), -- Cisco EIGRP
  63. dvmrp (17), -- DVMRP
  64. rpl (18), -- RPL [RFC-ietf-roll-rpl-19]
  65. dhcp (19), -- DHCP [RFC2132]
  66. ttdp (20) -- Train Topology Discovery Protocol (TTDP) [IEC 61375-2-5]
  67. }
  68. IANAipMRouteProtocol ::= TEXTUAL-CONVENTION
  69. STATUS current
  70. DESCRIPTION
  71. "The multicast routing protocol. Inclusion of values for
  72. multicast routing protocols is not intended to imply that
  73. those protocols need be supported."
  74. SYNTAX INTEGER {
  75. other(1), -- none of the following
  76. local(2), -- e.g., manually configured
  77. netmgmt(3), -- set via net.mgmt protocol
  78. dvmrp(4),
  79. mospf(5),
  80. pimSparseDense(6), -- PIMv1, both DM and SM
  81. cbt(7),
  82. pimSparseMode(8), -- PIM-SM
  83. pimDenseMode(9), -- PIM-DM
  84. igmpOnly(10),
  85. bgmp(11),
  86. msdp(12)
  87. }
  88. END