SCTP-MIB.txt 44 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394959697989910010110210310410510610710810911011111211311411511611711811912012112212312412512612712812913013113213313413513613713813914014114214314414514614714814915015115215315415515615715815916016116216316416516616716816917017117217317417517617717817918018118218318418518618718818919019119219319419519619719819920020120220320420520620720820921021121221321421521621721821922022122222322422522622722822923023123223323423523623723823924024124224324424524624724824925025125225325425525625725825926026126226326426526626726826927027127227327427527627727827928028128228328428528628728828929029129229329429529629729829930030130230330430530630730830931031131231331431531631731831932032132232332432532632732832933033133233333433533633733833934034134234334434534634734834935035135235335435535635735835936036136236336436536636736836937037137237337437537637737837938038138238338438538638738838939039139239339439539639739839940040140240340440540640740840941041141241341441541641741841942042142242342442542642742842943043143243343443543643743843944044144244344444544644744844945045145245345445545645745845946046146246346446546646746846947047147247347447547647747847948048148248348448548648748848949049149249349449549649749849950050150250350450550650750850951051151251351451551651751851952052152252352452552652752852953053153253353453553653753853954054154254354454554654754854955055155255355455555655755855956056156256356456556656756856957057157257357457557657757857958058158258358458558658758858959059159259359459559659759859960060160260360460560660760860961061161261361461561661761861962062162262362462562662762862963063163263363463563663763863964064164264364464564664764864965065165265365465565665765865966066166266366466566666766866967067167267367467567667767867968068168268368468568668768868969069169269369469569669769869970070170270370470570670770870971071171271371471571671771871972072172272372472572672772872973073173273373473573673773873974074174274374474574674774874975075175275375475575675775875976076176276376476576676776876977077177277377477577677777877978078178278378478578678778878979079179279379479579679779879980080180280380480580680780880981081181281381481581681781881982082182282382482582682782882983083183283383483583683783883984084184284384484584684784884985085185285385485585685785885986086186286386486586686786886987087187287387487587687787887988088188288388488588688788888989089189289389489589689789889990090190290390490590690790890991091191291391491591691791891992092192292392492592692792892993093193293393493593693793893994094194294394494594694794894995095195295395495595695795895996096196296396496596696796896997097197297397497597697797897998098198298398498598698798898999099199299399499599699799899910001001100210031004100510061007100810091010101110121013101410151016101710181019102010211022102310241025102610271028102910301031103210331034103510361037103810391040104110421043104410451046104710481049105010511052105310541055105610571058105910601061106210631064106510661067106810691070107110721073107410751076107710781079108010811082108310841085108610871088108910901091109210931094109510961097109810991100110111021103110411051106110711081109111011111112111311141115111611171118111911201121112211231124112511261127112811291130113111321133113411351136113711381139114011411142114311441145114611471148114911501151115211531154115511561157115811591160116111621163116411651166116711681169117011711172117311741175117611771178117911801181118211831184118511861187118811891190119111921193119411951196119711981199120012011202120312041205120612071208120912101211121212131214121512161217121812191220122112221223122412251226122712281229123012311232123312341235123612371238123912401241124212431244124512461247124812491250125112521253125412551256125712581259126012611262126312641265126612671268126912701271127212731274127512761277127812791280128112821283128412851286128712881289129012911292129312941295129612971298129913001301130213031304130513061307130813091310131113121313131413151316131713181319132013211322132313241325132613271328132913301331133213331334133513361337133813391340134113421343
  1. SCTP-MIB DEFINITIONS ::= BEGIN
  2. IMPORTS
  3. MODULE-IDENTITY, OBJECT-TYPE, Integer32, Unsigned32, Gauge32,
  4. Counter32, Counter64, mib-2
  5. FROM SNMPv2-SMI -- [RFC2578]
  6. TimeStamp, TruthValue
  7. FROM SNMPv2-TC -- [RFC2579]
  8. MODULE-COMPLIANCE, OBJECT-GROUP
  9. FROM SNMPv2-CONF -- [RFC2580]
  10. InetAddressType, InetAddress, InetPortNumber
  11. FROM INET-ADDRESS-MIB; -- [RFC3291]
  12. sctpMIB MODULE-IDENTITY
  13. LAST-UPDATED "200409020000Z" -- 2nd September 2004
  14. ORGANIZATION "IETF SIGTRAN Working Group"
  15. CONTACT-INFO
  16. "
  17. WG EMail: sigtran@ietf.org
  18. Web Page:
  19. http://www.ietf.org/html.charters/sigtran-charter.html
  20. Chair: Lyndon Ong
  21. Ciena Corporation
  22. 0480 Ridgeview Drive
  23. Cupertino, CA 95014
  24. USA
  25. Tel:
  26. Email: lyong@ciena.com
  27. Editors: Maria-Carmen Belinchon
  28. R&D Department
  29. Ericsson Espana S. A.
  30. Via de los Poblados, 13
  31. 28033 Madrid
  32. Spain
  33. Tel: +34 91 339 3535
  34. Email: Maria.C.Belinchon@ericsson.com
  35. Jose-Javier Pastor-Balbas
  36. R&D Department
  37. Ericsson Espana S. A.
  38. Via de los Poblados, 13
  39. 28033 Madrid
  40. Spain
  41. Tel: +34 91 339 1397
  42. Email: J.Javier.Pastor@ericsson.com
  43. "
  44. DESCRIPTION
  45. "The MIB module for managing SCTP implementations.
  46. Copyright (C) The Internet Society (2004). This version of
  47. this MIB module is part of RFC 3873; see the RFC itself for
  48. full legal notices. "
  49. REVISION "200409020000Z" -- 2nd September 2004
  50. DESCRIPTION " Initial version, published as RFC 3873"
  51. ::= { mib-2 104 }
  52. -- the SCTP base variables group
  53. sctpObjects OBJECT IDENTIFIER ::= { sctpMIB 1 }
  54. sctpStats OBJECT IDENTIFIER ::= { sctpObjects 1 }
  55. sctpParams OBJECT IDENTIFIER ::= { sctpObjects 2 }
  56. -- STATISTICS
  57. -- **********
  58. -- STATE-RELATED STATISTICS
  59. sctpCurrEstab OBJECT-TYPE
  60. SYNTAX Gauge32
  61. MAX-ACCESS read-only
  62. STATUS current
  63. DESCRIPTION
  64. "The number of associations for which the current state is
  65. either ESTABLISHED, SHUTDOWN-RECEIVED or SHUTDOWN-PENDING."
  66. REFERENCE
  67. "Section 4 in RFC2960 covers the SCTP Association state
  68. diagram."
  69. ::= { sctpStats 1 }
  70. sctpActiveEstabs OBJECT-TYPE
  71. SYNTAX Counter32
  72. MAX-ACCESS read-only
  73. STATUS current
  74. DESCRIPTION
  75. "The number of times that associations have made a direct
  76. transition to the ESTABLISHED state from the COOKIE-ECHOED
  77. state: COOKIE-ECHOED -> ESTABLISHED. The upper layer initiated
  78. the association attempt."
  79. REFERENCE
  80. "Section 4 in RFC2960 covers the SCTP Association state
  81. diagram."
  82. ::= { sctpStats 2 }
  83. sctpPassiveEstabs OBJECT-TYPE
  84. SYNTAX Counter32
  85. MAX-ACCESS read-only
  86. STATUS current
  87. DESCRIPTION
  88. "The number of times that associations have made a direct
  89. transition to the ESTABLISHED state from the CLOSED state:
  90. CLOSED -> ESTABLISHED. The remote endpoint initiated the
  91. association attempt."
  92. REFERENCE
  93. "Section 4 in RFC2960 covers the SCTP Association state
  94. diagram."
  95. ::= { sctpStats 3 }
  96. sctpAborteds OBJECT-TYPE
  97. SYNTAX Counter32
  98. MAX-ACCESS read-only
  99. STATUS current
  100. DESCRIPTION
  101. "The number of times that associations have made a direct
  102. transition to the CLOSED state from any state using the
  103. primitive 'ABORT': AnyState --Abort--> CLOSED. Ungraceful
  104. termination of the association."
  105. REFERENCE
  106. "Section 4 in RFC2960 covers the SCTP Association state
  107. diagram."
  108. ::= { sctpStats 4 }
  109. sctpShutdowns OBJECT-TYPE
  110. SYNTAX Counter32
  111. MAX-ACCESS read-only
  112. STATUS current
  113. DESCRIPTION
  114. "The number of times that associations have made a direct
  115. transition to the CLOSED state from either the SHUTDOWN-SENT
  116. state or the SHUTDOWN-ACK-SENT state. Graceful termination of
  117. the association."
  118. REFERENCE
  119. "Section 4 in RFC2960 covers the SCTP Association state
  120. diagram."
  121. ::= { sctpStats 5 }
  122. -- OTHER LAYER STATISTICS
  123. sctpOutOfBlues OBJECT-TYPE
  124. SYNTAX Counter32
  125. MAX-ACCESS read-only
  126. STATUS current
  127. DESCRIPTION
  128. "The number of out of the blue packets received by the host.
  129. An out of the blue packet is an SCTP packet correctly formed,
  130. including the proper checksum, but for which the receiver was
  131. unable to identify an appropriate association."
  132. REFERENCE
  133. "Section 8.4 in RFC2960 deals with the Out-Of-The-Blue
  134. (OOTB) packet definition and procedures."
  135. ::= { sctpStats 6 }
  136. sctpChecksumErrors OBJECT-TYPE
  137. SYNTAX Counter32
  138. MAX-ACCESS read-only
  139. STATUS current
  140. DESCRIPTION
  141. "The number of SCTP packets received with an invalid
  142. checksum."
  143. REFERENCE
  144. "The checksum is located at the end of the SCTP packet as per
  145. Section 3.1 in RFC2960. RFC3309 updates SCTP to use a 32 bit
  146. CRC checksum."
  147. ::= { sctpStats 7 }
  148. sctpOutCtrlChunks OBJECT-TYPE
  149. SYNTAX Counter64
  150. MAX-ACCESS read-only
  151. STATUS current
  152. DESCRIPTION
  153. "The number of SCTP control chunks sent (retransmissions are
  154. not included). Control chunks are those chunks different from
  155. DATA."
  156. REFERENCE
  157. "Sections 1.3.5 and 1.4 in RFC2960 refer to control chunk as
  158. those chunks different from those that contain user
  159. information, i.e., DATA chunks."
  160. ::= { sctpStats 8 }
  161. sctpOutOrderChunks OBJECT-TYPE
  162. SYNTAX Counter64
  163. MAX-ACCESS read-only
  164. STATUS current
  165. DESCRIPTION
  166. "The number of SCTP ordered data chunks sent (retransmissions
  167. are not included)."
  168. REFERENCE
  169. "Section 3.3.1 in RFC2960 defines the ordered data chunk."
  170. ::= { sctpStats 9 }
  171. sctpOutUnorderChunks OBJECT-TYPE
  172. SYNTAX Counter64
  173. MAX-ACCESS read-only
  174. STATUS current
  175. DESCRIPTION
  176. "The number of SCTP unordered chunks (data chunks in which the
  177. U bit is set to 1) sent (retransmissions are not included)."
  178. REFERENCE
  179. "Section 3.3.1 in RFC2960 defines the unordered data chunk."
  180. ::= { sctpStats 10 }
  181. sctpInCtrlChunks OBJECT-TYPE
  182. SYNTAX Counter64
  183. MAX-ACCESS read-only
  184. STATUS current
  185. DESCRIPTION
  186. "The number of SCTP control chunks received (no duplicate
  187. chunks included)."
  188. REFERENCE
  189. "Sections 1.3.5 and 1.4 in RFC2960 refer to control chunk as
  190. those chunks different from those that contain user
  191. information, i.e., DATA chunks."
  192. ::= { sctpStats 11 }
  193. sctpInOrderChunks OBJECT-TYPE
  194. SYNTAX Counter64
  195. MAX-ACCESS read-only
  196. STATUS current
  197. DESCRIPTION
  198. "The number of SCTP ordered data chunks received (no duplicate
  199. chunks included)."
  200. REFERENCE
  201. "Section 3.3.1 in RFC2960 defines the ordered data chunk."
  202. ::= { sctpStats 12 }
  203. sctpInUnorderChunks OBJECT-TYPE
  204. SYNTAX Counter64
  205. MAX-ACCESS read-only
  206. STATUS current
  207. DESCRIPTION
  208. "The number of SCTP unordered chunks (data chunks in which the
  209. U bit is set to 1) received (no duplicate chunks included)."
  210. REFERENCE
  211. "Section 3.3.1 in RFC2960 defines the unordered data chunk."
  212. ::= { sctpStats 13 }
  213. sctpFragUsrMsgs OBJECT-TYPE
  214. SYNTAX Counter64
  215. MAX-ACCESS read-only
  216. STATUS current
  217. DESCRIPTION
  218. "The number of user messages that have to be fragmented
  219. because of the MTU."
  220. ::= { sctpStats 14 }
  221. sctpReasmUsrMsgs OBJECT-TYPE
  222. SYNTAX Counter64
  223. MAX-ACCESS read-only
  224. STATUS current
  225. DESCRIPTION
  226. "The number of user messages reassembled, after conversion
  227. into DATA chunks."
  228. REFERENCE
  229. "Section 6.9 in RFC2960 includes a description of the
  230. reassembly process."
  231. ::= { sctpStats 15 }
  232. sctpOutSCTPPacks OBJECT-TYPE
  233. SYNTAX Counter64
  234. MAX-ACCESS read-only
  235. STATUS current
  236. DESCRIPTION
  237. "The number of SCTP packets sent. Retransmitted DATA chunks
  238. are included."
  239. ::= { sctpStats 16 }
  240. sctpInSCTPPacks OBJECT-TYPE
  241. SYNTAX Counter64
  242. MAX-ACCESS read-only
  243. STATUS current
  244. DESCRIPTION
  245. "The number of SCTP packets received. Duplicates are
  246. included."
  247. ::= { sctpStats 17 }
  248. sctpDiscontinuityTime OBJECT-TYPE
  249. SYNTAX TimeStamp
  250. MAX-ACCESS read-only
  251. STATUS current
  252. DESCRIPTION
  253. "The value of sysUpTime on the most recent occasion at which
  254. any one or more of this general statistics counters suffered a
  255. discontinuity. The relevant counters are the specific
  256. instances associated with this interface of any Counter32 or
  257. Counter64 object contained in the SCTP layer statistics
  258. (defined below sctpStats branch). If no such discontinuities
  259. have occurred since the last re-initialization of the local
  260. management subsystem, then this object contains a zero value."
  261. REFERENCE
  262. "The inclusion of this object is recommended by RFC2578."
  263. ::= { sctpStats 18 }
  264. -- PROTOCOL GENERAL VARIABLES
  265. -- **************************
  266. sctpRtoAlgorithm OBJECT-TYPE
  267. SYNTAX INTEGER {
  268. other(1), -- Other new one. Future use
  269. vanj(2) -- Van Jacobson's algorithm
  270. }
  271. MAX-ACCESS read-only
  272. STATUS current
  273. DESCRIPTION
  274. "The algorithm used to determine the timeout value (T3-rtx)
  275. used for re-transmitting unacknowledged chunks."
  276. REFERENCE
  277. "Section 6.3.1 and 6.3.2 in RFC2960 cover the RTO calculation
  278. and retransmission timer rules."
  279. DEFVAL {vanj} -- vanj(2)
  280. ::= { sctpParams 1 }
  281. sctpRtoMin OBJECT-TYPE
  282. SYNTAX Unsigned32
  283. UNITS "milliseconds"
  284. MAX-ACCESS read-only
  285. STATUS current
  286. DESCRIPTION
  287. "The minimum value permitted by a SCTP implementation for the
  288. retransmission timeout value, measured in milliseconds. More
  289. refined semantics for objects of this type depend upon the
  290. algorithm used to determine the retransmission timeout value.
  291. A retransmission time value of zero means immediate
  292. retransmission.
  293. The value of this object has to be lower than or equal to
  294. stcpRtoMax's value."
  295. DEFVAL {1000} -- milliseconds
  296. ::= { sctpParams 2 }
  297. sctpRtoMax OBJECT-TYPE
  298. SYNTAX Unsigned32
  299. UNITS "milliseconds"
  300. MAX-ACCESS read-only
  301. STATUS current
  302. DESCRIPTION
  303. "The maximum value permitted by a SCTP implementation for the
  304. retransmission timeout value, measured in milliseconds. More
  305. refined semantics for objects of this type depend upon the
  306. algorithm used to determine the retransmission timeout value.
  307. A retransmission time value of zero means immediate re-
  308. transmission.
  309. The value of this object has to be greater than or equal to
  310. stcpRtoMin's value."
  311. DEFVAL {60000} -- milliseconds
  312. ::= { sctpParams 3 }
  313. sctpRtoInitial OBJECT-TYPE
  314. SYNTAX Unsigned32
  315. UNITS "milliseconds"
  316. MAX-ACCESS read-only
  317. STATUS current
  318. DESCRIPTION
  319. "The initial value for the retransmission timer.
  320. A retransmission time value of zero means immediate re-
  321. transmission."
  322. DEFVAL {3000} -- milliseconds
  323. ::= { sctpParams 4 }
  324. sctpMaxAssocs OBJECT-TYPE
  325. SYNTAX Integer32 (-1 | 0..2147483647)
  326. MAX-ACCESS read-only
  327. STATUS current
  328. DESCRIPTION
  329. "The limit on the total number of associations the entity can
  330. support. In entities where the maximum number of associations
  331. is dynamic, this object should contain the value -1."
  332. ::= { sctpParams 5 }
  333. sctpValCookieLife OBJECT-TYPE
  334. SYNTAX Unsigned32
  335. UNITS "milliseconds"
  336. MAX-ACCESS read-only
  337. STATUS current
  338. DESCRIPTION
  339. "Valid cookie life in the 4-way start-up handshake procedure."
  340. REFERENCE
  341. "Section 5.1.3 in RFC2960 explains the cookie generation
  342. process. Recommended value is per section 14 in RFC2960."
  343. DEFVAL {60000} -- milliseconds
  344. ::= { sctpParams 6 }
  345. sctpMaxInitRetr OBJECT-TYPE
  346. SYNTAX Unsigned32
  347. MAX-ACCESS read-only
  348. STATUS current
  349. DESCRIPTION
  350. "The maximum number of retransmissions at the start-up phase
  351. (INIT and COOKIE ECHO chunks). "
  352. REFERENCE
  353. "Section 5.1.4, 5.1.6 in RFC2960 refers to Max.Init.Retransmit
  354. parameter. Recommended value is per section 14 in RFC2960."
  355. DEFVAL {8} -- number of attempts
  356. ::= { sctpParams 7 }
  357. -- TABLES
  358. -- ******
  359. -- the SCTP Association TABLE
  360. -- The SCTP association table contains information about each
  361. -- association in which the local endpoint is involved.
  362. sctpAssocTable OBJECT-TYPE
  363. SYNTAX SEQUENCE OF SctpAssocEntry
  364. MAX-ACCESS not-accessible
  365. STATUS current
  366. DESCRIPTION
  367. "A table containing SCTP association-specific information."
  368. ::= { sctpObjects 3 }
  369. sctpAssocEntry OBJECT-TYPE
  370. SYNTAX SctpAssocEntry
  371. MAX-ACCESS not-accessible
  372. STATUS current
  373. DESCRIPTION
  374. "General common variables and statistics for the whole
  375. association."
  376. INDEX { sctpAssocId }
  377. ::= { sctpAssocTable 1 }
  378. SctpAssocEntry ::= SEQUENCE {
  379. sctpAssocId Unsigned32,
  380. sctpAssocRemHostName OCTET STRING,
  381. sctpAssocLocalPort InetPortNumber,
  382. sctpAssocRemPort InetPortNumber,
  383. sctpAssocRemPrimAddrType InetAddressType,
  384. sctpAssocRemPrimAddr InetAddress,
  385. sctpAssocHeartBeatInterval Unsigned32,
  386. sctpAssocState INTEGER,
  387. sctpAssocInStreams Unsigned32,
  388. sctpAssocOutStreams Unsigned32,
  389. sctpAssocMaxRetr Unsigned32,
  390. sctpAssocPrimProcess Unsigned32,
  391. sctpAssocT1expireds Counter32, -- Statistic
  392. sctpAssocT2expireds Counter32, -- Statistic
  393. sctpAssocRtxChunks Counter32, -- Statistic
  394. sctpAssocStartTime TimeStamp,
  395. sctpAssocDiscontinuityTime TimeStamp
  396. }
  397. sctpAssocId OBJECT-TYPE
  398. SYNTAX Unsigned32 (1..4294967295)
  399. MAX-ACCESS not-accessible
  400. STATUS current
  401. DESCRIPTION
  402. "Association Identification. Value identifying the
  403. association. "
  404. ::= { sctpAssocEntry 1 }
  405. sctpAssocRemHostName OBJECT-TYPE
  406. SYNTAX OCTET STRING (SIZE(0..255))
  407. MAX-ACCESS read-only
  408. STATUS current
  409. DESCRIPTION
  410. "The peer's DNS name. This object needs to have the same
  411. format as the encoding in the DNS protocol. This implies that
  412. the domain name can be up to 255 octets long, each octet being
  413. 0<=x<=255 as value with US-ASCII A-Z having a case insensitive
  414. matching.
  415. If no DNS domain name was received from the peer at init time
  416. (embedded in the INIT or INIT-ACK chunk), this object is
  417. meaningless. In such cases the object MUST contain a zero-
  418. length string value. Otherwise, it contains the remote host
  419. name received at init time."
  420. ::= { sctpAssocEntry 2 }
  421. sctpAssocLocalPort OBJECT-TYPE
  422. SYNTAX InetPortNumber (1..65535)
  423. MAX-ACCESS read-only
  424. STATUS current
  425. DESCRIPTION
  426. "The local SCTP port number used for this association."
  427. ::= { sctpAssocEntry 3 }
  428. sctpAssocRemPort OBJECT-TYPE
  429. SYNTAX InetPortNumber (1..65535)
  430. MAX-ACCESS read-only
  431. STATUS current
  432. DESCRIPTION
  433. "The remote SCTP port number used for this association."
  434. ::= { sctpAssocEntry 4 }
  435. sctpAssocRemPrimAddrType OBJECT-TYPE
  436. SYNTAX InetAddressType
  437. MAX-ACCESS read-only
  438. STATUS current
  439. DESCRIPTION
  440. "The internet type of primary remote IP address. "
  441. ::= { sctpAssocEntry 5 }
  442. sctpAssocRemPrimAddr OBJECT-TYPE
  443. SYNTAX InetAddress
  444. MAX-ACCESS read-only
  445. STATUS current
  446. DESCRIPTION
  447. "The primary remote IP address. The type of this address is
  448. determined by the value of sctpAssocRemPrimAddrType.
  449. The client side will know this value after INIT_ACK message
  450. reception, the server side will know this value when sending
  451. INIT_ACK message. However, values will be filled in at
  452. established(4) state."
  453. ::= { sctpAssocEntry 6 }
  454. sctpAssocHeartBeatInterval OBJECT-TYPE
  455. SYNTAX Unsigned32
  456. UNITS "milliseconds"
  457. MAX-ACCESS read-only
  458. STATUS current
  459. DESCRIPTION
  460. "The current heartbeat interval..
  461. Zero value means no HeartBeat, even when the concerned
  462. sctpAssocRemAddrHBFlag object is true."
  463. DEFVAL {30000} -- milliseconds
  464. ::= { sctpAssocEntry 7 }
  465. sctpAssocState OBJECT-TYPE
  466. SYNTAX INTEGER {
  467. closed(1),
  468. cookieWait(2),
  469. cookieEchoed(3),
  470. established(4),
  471. shutdownPending(5),
  472. shutdownSent(6),
  473. shutdownReceived(7),
  474. shutdownAckSent(8),
  475. deleteTCB(9)
  476. }
  477. MAX-ACCESS read-write
  478. STATUS current
  479. DESCRIPTION
  480. "The state of this SCTP association.
  481. As in TCP, deleteTCB(9) is the only value that may be set by a
  482. management station. If any other value is received, then the
  483. agent must return a wrongValue error.
  484. If a management station sets this object to the value
  485. deleteTCB(9), then this has the effect of deleting the TCB (as
  486. defined in SCTP) of the corresponding association on the
  487. managed node, resulting in immediate termination of the
  488. association.
  489. As an implementation-specific option, an ABORT chunk may be
  490. sent from the managed node to the other SCTP endpoint as a
  491. result of setting the deleteTCB(9) value. The ABORT chunk
  492. implies an ungraceful association shutdown."
  493. REFERENCE
  494. "Section 4 in RFC2960 covers the SCTP Association state
  495. diagram."
  496. ::= { sctpAssocEntry 8 }
  497. sctpAssocInStreams OBJECT-TYPE
  498. SYNTAX Unsigned32 (1..65535)
  499. MAX-ACCESS read-only
  500. STATUS current
  501. DESCRIPTION
  502. "Inbound Streams according to the negotiation at association
  503. start up."
  504. REFERENCE
  505. "Section 1.3 in RFC2960 includes a definition of stream.
  506. Section 5.1.1 in RFC2960 covers the streams negotiation
  507. process."
  508. ::= { sctpAssocEntry 9 }
  509. sctpAssocOutStreams OBJECT-TYPE
  510. SYNTAX Unsigned32 (1..65535)
  511. MAX-ACCESS read-only
  512. STATUS current
  513. DESCRIPTION
  514. "Outbound Streams according to the negotiation at association
  515. start up. "
  516. REFERENCE
  517. "Section 1.3 in RFC2960 includes a definition of stream.
  518. Section 5.1.1 in RFC2960 covers the streams negotiation
  519. process."
  520. ::= { sctpAssocEntry 10 }
  521. sctpAssocMaxRetr OBJECT-TYPE
  522. SYNTAX Unsigned32
  523. MAX-ACCESS read-only
  524. STATUS current
  525. DESCRIPTION
  526. "The maximum number of data retransmissions in the association
  527. context. This value is specific for each association and the
  528. upper layer can change it by calling the appropriate
  529. primitives. This value has to be smaller than the addition of
  530. all the maximum number for all the paths
  531. (sctpAssocRemAddrMaxPathRtx).
  532. A value of zero value means no retransmissions."
  533. DEFVAL {10} -- number of attempts
  534. ::= { sctpAssocEntry 11 }
  535. sctpAssocPrimProcess OBJECT-TYPE
  536. SYNTAX Unsigned32
  537. MAX-ACCESS read-only
  538. STATUS current
  539. DESCRIPTION
  540. "This object identifies the system level process which holds
  541. primary responsibility for the SCTP association.
  542. Wherever possible, this should be the system's native unique
  543. identification number. The special value 0 can be used to
  544. indicate that no primary process is known.
  545. Note that the value of this object can be used as a pointer
  546. into the swRunTable of the HOST-RESOURCES-MIB(if the value is
  547. smaller than 2147483647) or into the sysApplElmtRunTable of
  548. the SYSAPPL-MIB."
  549. ::= { sctpAssocEntry 12 }
  550. -- Association Statistics
  551. sctpAssocT1expireds OBJECT-TYPE
  552. SYNTAX Counter32
  553. MAX-ACCESS read-only
  554. STATUS current
  555. DESCRIPTION
  556. "The T1 timer determines how long to wait for an
  557. acknowledgement after sending an INIT or COOKIE-ECHO chunk.
  558. This object reflects the number of times the T1 timer expires
  559. without having received the acknowledgement.
  560. Discontinuities in the value of this counter can occur at re-
  561. initialization of the management system, and at other times as
  562. indicated by the value of sctpAssocDiscontinuityTime."
  563. REFERENCE
  564. "Section 5 in RFC2960."
  565. ::= { sctpAssocEntry 13 }
  566. sctpAssocT2expireds OBJECT-TYPE
  567. SYNTAX Counter32
  568. MAX-ACCESS read-only
  569. STATUS current
  570. DESCRIPTION
  571. "The T2 timer determines how long to wait for an
  572. acknowledgement after sending a SHUTDOWN or SHUTDOWN-ACK
  573. chunk. This object reflects the number of times that T2- timer
  574. expired.
  575. Discontinuities in the value of this counter can occur at re-
  576. initialization of the management system, and at other times as
  577. indicated by the value of sctpAssocDiscontinuityTime."
  578. REFERENCE
  579. "Section 9.2 in RFC2960."
  580. ::= { sctpAssocEntry 14 }
  581. sctpAssocRtxChunks OBJECT-TYPE
  582. SYNTAX Counter32
  583. MAX-ACCESS read-only
  584. STATUS current
  585. DESCRIPTION
  586. "When T3-rtx expires, the DATA chunks that triggered the T3
  587. timer will be re-sent according with the retransmissions
  588. rules. Every DATA chunk that was included in the SCTP packet
  589. that triggered the T3-rtx timer must be added to the value of
  590. this counter.
  591. Discontinuities in the value of this counter can occur at re-
  592. initialization of the management system, and at other times as
  593. indicated by the value of sctpAssocDiscontinuityTime."
  594. REFERENCE
  595. "Section 6 in RFC2960 covers the retransmission process and
  596. rules."
  597. ::= { sctpAssocEntry 15 }
  598. sctpAssocStartTime OBJECT-TYPE
  599. SYNTAX TimeStamp
  600. MAX-ACCESS read-only
  601. STATUS current
  602. DESCRIPTION
  603. "The value of sysUpTime at the time that the association
  604. represented by this row enters the ESTABLISHED state, i.e.,
  605. the sctpAssocState object is set to established(4). The
  606. value of this object will be zero:
  607. - before the association enters the established(4)
  608. state, or
  609. - if the established(4) state was entered prior to
  610. the last re-initialization of the local network management
  611. subsystem."
  612. ::= { sctpAssocEntry 16 }
  613. sctpAssocDiscontinuityTime OBJECT-TYPE
  614. SYNTAX TimeStamp
  615. MAX-ACCESS read-only
  616. STATUS current
  617. DESCRIPTION
  618. "The value of sysUpTime on the most recent occasion at which
  619. any one or more of this SCTP association counters suffered a
  620. discontinuity. The relevant counters are the specific
  621. instances associated with this interface of any Counter32 or
  622. Counter64 object contained in the sctpAssocTable or
  623. sctpLocalAddrTable or sctpRemAddrTable. If no such
  624. discontinuities have occurred since the last re-initialization
  625. of the local management subsystem, then this object contains a
  626. zero value. "
  627. REFERENCE
  628. "The inclusion of this object is recommended by RFC2578."
  629. ::= { sctpAssocEntry 17 }
  630. -- Expanded tables: Including Multi-home feature
  631. -- Local Address TABLE
  632. -- *******************
  633. sctpAssocLocalAddrTable OBJECT-TYPE
  634. SYNTAX SEQUENCE OF SctpAssocLocalAddrEntry
  635. MAX-ACCESS not-accessible
  636. STATUS current
  637. DESCRIPTION
  638. "Expanded table of sctpAssocTable based on the AssocId index.
  639. This table shows data related to each local IP address which
  640. is used by this association."
  641. ::= { sctpObjects 4 }
  642. sctpAssocLocalAddrEntry OBJECT-TYPE
  643. SYNTAX SctpAssocLocalAddrEntry
  644. MAX-ACCESS not-accessible
  645. STATUS current
  646. DESCRIPTION
  647. "Local information about the available addresses. There will
  648. be an entry for every local IP address defined for this
  649. association.
  650. Implementors need to be aware that if the size of
  651. sctpAssocLocalAddr exceeds 114 octets then OIDs of column
  652. instances in this table will have more than 128 sub-
  653. identifiers and cannot be accessed using SNMPv1, SNMPv2c, or
  654. SNMPv3."
  655. INDEX { sctpAssocId, -- shared index
  656. sctpAssocLocalAddrType,
  657. sctpAssocLocalAddr }
  658. ::= { sctpAssocLocalAddrTable 1 }
  659. SctpAssocLocalAddrEntry ::= SEQUENCE {
  660. sctpAssocLocalAddrType InetAddressType,
  661. sctpAssocLocalAddr InetAddress,
  662. sctpAssocLocalAddrStartTime TimeStamp
  663. }
  664. sctpAssocLocalAddrType OBJECT-TYPE
  665. SYNTAX InetAddressType
  666. MAX-ACCESS not-accessible
  667. STATUS current
  668. DESCRIPTION
  669. "Internet type of local IP address used for this association."
  670. ::= { sctpAssocLocalAddrEntry 1 }
  671. sctpAssocLocalAddr OBJECT-TYPE
  672. SYNTAX InetAddress
  673. MAX-ACCESS not-accessible
  674. STATUS current
  675. DESCRIPTION
  676. "The value of a local IP address available for this
  677. association. The type of this address is determined by the
  678. value of sctpAssocLocalAddrType."
  679. ::= { sctpAssocLocalAddrEntry 2 }
  680. sctpAssocLocalAddrStartTime OBJECT-TYPE
  681. SYNTAX TimeStamp
  682. MAX-ACCESS read-only
  683. STATUS current
  684. DESCRIPTION
  685. "The value of sysUpTime at the time that this row was
  686. created."
  687. ::= { sctpAssocLocalAddrEntry 3 }
  688. -- Remote Addresses TABLE
  689. -- **********************
  690. sctpAssocRemAddrTable OBJECT-TYPE
  691. SYNTAX SEQUENCE OF SctpAssocRemAddrEntry
  692. MAX-ACCESS not-accessible
  693. STATUS current
  694. DESCRIPTION
  695. "Expanded table of sctpAssocTable based on the AssocId index.
  696. This table shows data related to each remote peer IP address
  697. which is used by this association."
  698. ::= { sctpObjects 5 }
  699. sctpAssocRemAddrEntry OBJECT-TYPE
  700. SYNTAX SctpAssocRemAddrEntry
  701. MAX-ACCESS not-accessible
  702. STATUS current
  703. DESCRIPTION
  704. "Information about the most important variables for every
  705. remote IP address. There will be an entry for every remote IP
  706. address defined for this association.
  707. Implementors need to be aware that if the size of
  708. sctpAssocRemAddr exceeds 114 octets then OIDs of column
  709. instances in this table will have more than 128 sub-
  710. identifiers and cannot be accessed using SNMPv1, SNMPv2c, or
  711. SNMPv3."
  712. INDEX { sctpAssocId, -- shared index
  713. sctpAssocRemAddrType,
  714. sctpAssocRemAddr }
  715. ::= { sctpAssocRemAddrTable 1 }
  716. SctpAssocRemAddrEntry ::= SEQUENCE {
  717. sctpAssocRemAddrType InetAddressType,
  718. sctpAssocRemAddr InetAddress,
  719. sctpAssocRemAddrActive TruthValue,
  720. sctpAssocRemAddrHBActive TruthValue,
  721. sctpAssocRemAddrRTO Unsigned32,
  722. sctpAssocRemAddrMaxPathRtx Unsigned32,
  723. sctpAssocRemAddrRtx Counter32, -- Statistic
  724. sctpAssocRemAddrStartTime TimeStamp
  725. }
  726. sctpAssocRemAddrType OBJECT-TYPE
  727. SYNTAX InetAddressType
  728. MAX-ACCESS not-accessible
  729. STATUS current
  730. DESCRIPTION
  731. "Internet type of a remote IP address available for this
  732. association."
  733. ::= { sctpAssocRemAddrEntry 1 }
  734. sctpAssocRemAddr OBJECT-TYPE
  735. SYNTAX InetAddress
  736. MAX-ACCESS not-accessible
  737. STATUS current
  738. DESCRIPTION
  739. "The value of a remote IP address available for this
  740. association. The type of this address is determined by the
  741. value of sctpAssocLocalAddrType."
  742. ::= { sctpAssocRemAddrEntry 2 }
  743. sctpAssocRemAddrActive OBJECT-TYPE
  744. SYNTAX TruthValue
  745. MAX-ACCESS read-only
  746. STATUS current
  747. DESCRIPTION
  748. "This object gives information about the reachability of this
  749. specific remote IP address.
  750. When the object is set to 'true' (1), the remote IP address is
  751. understood as Active. Active means that the threshold of no
  752. answers received from this IP address has not been reached.
  753. When the object is set to 'false' (2), the remote IP address
  754. is understood as Inactive. Inactive means that either no
  755. heartbeat or any other message was received from this address,
  756. reaching the threshold defined by the protocol."
  757. REFERENCE
  758. "The remote transport states are defined as Active and
  759. Inactive in the SCTP, RFC2960."
  760. ::= { sctpAssocRemAddrEntry 3 }
  761. sctpAssocRemAddrHBActive OBJECT-TYPE
  762. SYNTAX TruthValue
  763. MAX-ACCESS read-only
  764. STATUS current
  765. DESCRIPTION
  766. "This object indicates whether the optional Heartbeat check
  767. associated to one destination transport address is activated
  768. or not (value equal to true or false, respectively). "
  769. ::= { sctpAssocRemAddrEntry 4 }
  770. sctpAssocRemAddrRTO OBJECT-TYPE -- T3-rtx- Timer
  771. SYNTAX Unsigned32
  772. UNITS "milliseconds"
  773. MAX-ACCESS read-only
  774. STATUS current
  775. DESCRIPTION
  776. "The current Retransmission Timeout. T3-rtx timer as defined
  777. in the protocol SCTP."
  778. REFERENCE
  779. "Section 6.3 in RFC2960 deals with the Retransmission Timer
  780. Management."
  781. ::= { sctpAssocRemAddrEntry 5 }
  782. sctpAssocRemAddrMaxPathRtx OBJECT-TYPE
  783. SYNTAX Unsigned32
  784. MAX-ACCESS read-only
  785. STATUS current
  786. DESCRIPTION
  787. "Maximum number of DATA chunks retransmissions allowed to a
  788. remote IP address before it is considered inactive, as defined
  789. in RFC2960."
  790. REFERENCE
  791. "Section 8.2, 8.3 and 14 in RFC2960."
  792. DEFVAL {5} -- number of attempts
  793. ::= { sctpAssocRemAddrEntry 6 }
  794. -- Remote Address Statistic
  795. sctpAssocRemAddrRtx OBJECT-TYPE
  796. SYNTAX Counter32
  797. MAX-ACCESS read-only
  798. STATUS current
  799. DESCRIPTION
  800. "Number of DATA chunks retransmissions to this specific IP
  801. address. When T3-rtx expires, the DATA chunk that triggered
  802. the T3 timer will be re-sent according to the retransmissions
  803. rules. Every DATA chunk that is included in a SCTP packet and
  804. was transmitted to this specific IP address before, will be
  805. included in this counter.
  806. Discontinuities in the value of this counter can occur at re-
  807. initialization of the management system, and at other times as
  808. indicated by the value of sctpAssocDiscontinuityTime."
  809. ::= { sctpAssocRemAddrEntry 7 }
  810. sctpAssocRemAddrStartTime OBJECT-TYPE
  811. SYNTAX TimeStamp
  812. MAX-ACCESS read-only
  813. STATUS current
  814. DESCRIPTION
  815. "The value of sysUpTime at the time that this row was
  816. created."
  817. ::= { sctpAssocRemAddrEntry 8 }
  818. -- ASSOCIATION INVERSE TABLE
  819. -- *************************
  820. -- BY LOCAL PORT
  821. sctpLookupLocalPortTable OBJECT-TYPE
  822. SYNTAX SEQUENCE OF SctpLookupLocalPortEntry
  823. MAX-ACCESS not-accessible
  824. STATUS current
  825. DESCRIPTION
  826. "With the use of this table, a list of associations which are
  827. using the specified local port can be retrieved."
  828. ::= { sctpObjects 6 }
  829. sctpLookupLocalPortEntry OBJECT-TYPE
  830. SYNTAX SctpLookupLocalPortEntry
  831. MAX-ACCESS not-accessible
  832. STATUS current
  833. DESCRIPTION
  834. "This table is indexed by local port and association ID.
  835. Specifying a local port, we would get a list of the
  836. associations whose local port is the one specified."
  837. INDEX { sctpAssocLocalPort,
  838. sctpAssocId }
  839. ::= { sctpLookupLocalPortTable 1 }
  840. SctpLookupLocalPortEntry::= SEQUENCE {
  841. sctpLookupLocalPortStartTime TimeStamp
  842. }
  843. sctpLookupLocalPortStartTime OBJECT-TYPE
  844. SYNTAX TimeStamp
  845. MAX-ACCESS read-only
  846. STATUS current
  847. DESCRIPTION
  848. "The value of sysUpTime at the time that this row was created.
  849. As the table will be created after the sctpAssocTable
  850. creation, this value could be equal to the sctpAssocStartTime
  851. object from the main table."
  852. ::= { sctpLookupLocalPortEntry 1 }
  853. -- BY REMOTE PORT
  854. sctpLookupRemPortTable OBJECT-TYPE
  855. SYNTAX SEQUENCE OF SctpLookupRemPortEntry
  856. MAX-ACCESS not-accessible
  857. STATUS current
  858. DESCRIPTION
  859. "With the use of this table, a list of associations which are
  860. using the specified remote port can be got"
  861. ::= { sctpObjects 7 }
  862. sctpLookupRemPortEntry OBJECT-TYPE
  863. SYNTAX SctpLookupRemPortEntry
  864. MAX-ACCESS not-accessible
  865. STATUS current
  866. DESCRIPTION
  867. "This table is indexed by remote port and association ID.
  868. Specifying a remote port we would get a list of the
  869. associations whose local port is the one specified "
  870. INDEX { sctpAssocRemPort,
  871. sctpAssocId }
  872. ::= { sctpLookupRemPortTable 1 }
  873. SctpLookupRemPortEntry::= SEQUENCE {
  874. sctpLookupRemPortStartTime TimeStamp
  875. }
  876. sctpLookupRemPortStartTime OBJECT-TYPE
  877. SYNTAX TimeStamp
  878. MAX-ACCESS read-only
  879. STATUS current
  880. DESCRIPTION
  881. "The value of sysUpTime at the time that this row was created.
  882. As the table will be created after the sctpAssocTable
  883. creation, this value could be equal to the sctpAssocStartTime
  884. object from the main table."
  885. ::= { sctpLookupRemPortEntry 1 }
  886. -- BY REMOTE HOST NAME
  887. sctpLookupRemHostNameTable OBJECT-TYPE
  888. SYNTAX SEQUENCE OF SctpLookupRemHostNameEntry
  889. MAX-ACCESS not-accessible
  890. STATUS current
  891. DESCRIPTION
  892. "With the use of this table, a list of associations with that
  893. particular host can be retrieved."
  894. ::= { sctpObjects 8 }
  895. sctpLookupRemHostNameEntry OBJECT-TYPE
  896. SYNTAX SctpLookupRemHostNameEntry
  897. MAX-ACCESS not-accessible
  898. STATUS current
  899. DESCRIPTION
  900. "This table is indexed by remote host name and association ID.
  901. Specifying a host name we would get a list of the associations
  902. specifying that host name as the remote one.
  903. Implementors need to be aware that if the size of
  904. sctpAssocRemHostName exceeds 115 octets then OIDs of column
  905. instances in this table will have more than 128 sub-
  906. identifiers and cannot be accessed using SNMPv1, SNMPv2c, or
  907. SNMPv3."
  908. INDEX { sctpAssocRemHostName,
  909. sctpAssocId }
  910. ::= { sctpLookupRemHostNameTable 1 }
  911. SctpLookupRemHostNameEntry::= SEQUENCE {
  912. sctpLookupRemHostNameStartTime TimeStamp
  913. }
  914. sctpLookupRemHostNameStartTime OBJECT-TYPE
  915. SYNTAX TimeStamp
  916. MAX-ACCESS read-only
  917. STATUS current
  918. DESCRIPTION
  919. "The value of sysUpTime at the time that this row was created.
  920. As the table will be created after the sctpAssocTable
  921. creation, this value could be equal to the sctpAssocStartTime
  922. object from the main table."
  923. ::= { sctpLookupRemHostNameEntry 1 }
  924. -- BY REMOTE PRIMARY IP ADDRESS
  925. sctpLookupRemPrimIPAddrTable OBJECT-TYPE
  926. SYNTAX SEQUENCE OF SctpLookupRemPrimIPAddrEntry
  927. MAX-ACCESS not-accessible
  928. STATUS current
  929. DESCRIPTION
  930. "With the use of this table, a list of associations that have
  931. the specified IP address as primary within the remote set of
  932. active addresses can be retrieved."
  933. ::= { sctpObjects 9 }
  934. sctpLookupRemPrimIPAddrEntry OBJECT-TYPE
  935. SYNTAX SctpLookupRemPrimIPAddrEntry
  936. MAX-ACCESS not-accessible
  937. STATUS current
  938. DESCRIPTION
  939. "This table is indexed by primary address and association ID.
  940. Specifying a primary address, we would get a list of the
  941. associations that have the specified remote IP address marked
  942. as primary.
  943. Implementors need to be aware that if the size of
  944. sctpAssocRemPrimAddr exceeds 114 octets then OIDs of column
  945. instances in this table will have more than 128 sub-
  946. identifiers and cannot be accessed using SNMPv1, SNMPv2c, or
  947. SNMPv3."
  948. INDEX { sctpAssocRemPrimAddrType,
  949. sctpAssocRemPrimAddr,
  950. sctpAssocId }
  951. ::= { sctpLookupRemPrimIPAddrTable 1 }
  952. SctpLookupRemPrimIPAddrEntry::= SEQUENCE {
  953. sctpLookupRemPrimIPAddrStartTime TimeStamp
  954. }
  955. sctpLookupRemPrimIPAddrStartTime OBJECT-TYPE
  956. SYNTAX TimeStamp
  957. MAX-ACCESS read-only
  958. STATUS current
  959. DESCRIPTION
  960. "The value of SysUpTime at the time that this row was created.
  961. As the table will be created after the sctpAssocTable
  962. creation, this value could be equal to the sctpAssocStartTime
  963. object from the main table."
  964. ::= { sctpLookupRemPrimIPAddrEntry 1 }
  965. -- BY REMOTE IP ADDRESS
  966. sctpLookupRemIPAddrTable OBJECT-TYPE
  967. SYNTAX SEQUENCE OF SctpLookupRemIPAddrEntry
  968. MAX-ACCESS not-accessible
  969. STATUS current
  970. DESCRIPTION
  971. "With the use of this table, a list of associations that have
  972. the specified IP address as one of the remote ones can be
  973. retrieved. "
  974. ::= { sctpObjects 10 }
  975. sctpLookupRemIPAddrEntry OBJECT-TYPE
  976. SYNTAX SctpLookupRemIPAddrEntry
  977. MAX-ACCESS not-accessible
  978. STATUS current
  979. DESCRIPTION
  980. "This table is indexed by a remote IP address and association
  981. ID. Specifying an IP address we would get a list of the
  982. associations that have the specified IP address included
  983. within the set of remote IP addresses."
  984. INDEX { sctpAssocRemAddrType,
  985. sctpAssocRemAddr,
  986. sctpAssocId }
  987. ::= { sctpLookupRemIPAddrTable 1 }
  988. SctpLookupRemIPAddrEntry::= SEQUENCE {
  989. sctpLookupRemIPAddrStartTime TimeStamp
  990. }
  991. sctpLookupRemIPAddrStartTime OBJECT-TYPE
  992. SYNTAX TimeStamp
  993. MAX-ACCESS read-only
  994. STATUS current
  995. DESCRIPTION
  996. "The value of SysUpTime at the time that this row was created.
  997. As the table will be created after the sctpAssocTable
  998. creation, this value could be equal to the sctpAssocStartTime
  999. object from the main table."
  1000. ::= { sctpLookupRemIPAddrEntry 1 }
  1001. -- 4.1 Conformance Information
  1002. sctpMibConformance OBJECT IDENTIFIER ::= { sctpMIB 2 }
  1003. sctpMibCompliances OBJECT IDENTIFIER ::= { sctpMibConformance 1 }
  1004. sctpMibGroups OBJECT IDENTIFIER ::= { sctpMibConformance 2 }
  1005. -- 4.1.1 Units of conformance
  1006. --
  1007. -- MODULE GROUPS
  1008. --
  1009. sctpLayerParamsGroup OBJECT-GROUP
  1010. OBJECTS { sctpRtoAlgorithm,
  1011. sctpRtoMin,
  1012. sctpRtoMax,
  1013. sctpRtoInitial,
  1014. sctpMaxAssocs,
  1015. sctpValCookieLife,
  1016. sctpMaxInitRetr
  1017. }
  1018. STATUS current
  1019. DESCRIPTION
  1020. "Common parameters for the SCTP layer, i.e., for all the
  1021. associations. They can usually be referred to as configuration
  1022. parameters."
  1023. ::= { sctpMibGroups 1 }
  1024. sctpStatsGroup OBJECT-GROUP
  1025. OBJECTS { sctpCurrEstab,
  1026. sctpActiveEstabs,
  1027. sctpPassiveEstabs,
  1028. sctpAborteds,
  1029. sctpShutdowns,
  1030. sctpOutOfBlues,
  1031. sctpChecksumErrors,
  1032. sctpOutCtrlChunks,
  1033. sctpOutOrderChunks,
  1034. sctpOutUnorderChunks,
  1035. sctpInCtrlChunks,
  1036. sctpInOrderChunks,
  1037. sctpInUnorderChunks,
  1038. sctpFragUsrMsgs,
  1039. sctpReasmUsrMsgs,
  1040. sctpOutSCTPPacks,
  1041. sctpInSCTPPacks,
  1042. sctpDiscontinuityTime,
  1043. sctpAssocT1expireds,
  1044. sctpAssocT2expireds,
  1045. sctpAssocRtxChunks,
  1046. sctpAssocRemAddrRtx
  1047. }
  1048. STATUS current
  1049. DESCRIPTION
  1050. "Statistics group. It includes the objects to collect state
  1051. changes in the SCTP protocol local layer and flow control
  1052. statistics."
  1053. ::= { sctpMibGroups 2 }
  1054. sctpPerAssocParamsGroup OBJECT-GROUP
  1055. OBJECTS { sctpAssocRemHostName,
  1056. sctpAssocLocalPort,
  1057. sctpAssocRemPort,
  1058. sctpAssocRemPrimAddrType,
  1059. sctpAssocRemPrimAddr,
  1060. sctpAssocHeartBeatInterval,
  1061. sctpAssocState,
  1062. sctpAssocInStreams,
  1063. sctpAssocOutStreams,
  1064. sctpAssocMaxRetr,
  1065. sctpAssocPrimProcess,
  1066. sctpAssocStartTime,
  1067. sctpAssocDiscontinuityTime,
  1068. sctpAssocLocalAddrStartTime,
  1069. sctpAssocRemAddrActive,
  1070. sctpAssocRemAddrHBActive,
  1071. sctpAssocRemAddrRTO,
  1072. sctpAssocRemAddrMaxPathRtx,
  1073. sctpAssocRemAddrStartTime
  1074. }
  1075. STATUS current
  1076. DESCRIPTION
  1077. "The SCTP group of objects to manage per-association
  1078. parameters. These variables include all the SCTP basic
  1079. features."
  1080. ::= { sctpMibGroups 3 }
  1081. sctpPerAssocStatsGroup OBJECT-GROUP
  1082. OBJECTS
  1083. { sctpAssocT1expireds,
  1084. sctpAssocT2expireds,
  1085. sctpAssocRtxChunks,
  1086. sctpAssocRemAddrRtx
  1087. }
  1088. STATUS current
  1089. DESCRIPTION
  1090. "Per Association Statistics group. It includes the objects to
  1091. collect flow control statistics per association."
  1092. ::= { sctpMibGroups 4 }
  1093. sctpInverseGroup OBJECT-GROUP
  1094. OBJECTS { sctpLookupLocalPortStartTime,
  1095. sctpLookupRemPortStartTime,
  1096. sctpLookupRemHostNameStartTime,
  1097. sctpLookupRemPrimIPAddrStartTime,
  1098. sctpLookupRemIPAddrStartTime
  1099. }
  1100. STATUS current
  1101. DESCRIPTION
  1102. "Objects used in the inverse lookup tables."
  1103. ::= { sctpMibGroups 5 }
  1104. -- 4.1.2 Compliance Statements
  1105. --
  1106. -- MODULE COMPLIANCES
  1107. --
  1108. sctpMibCompliance MODULE-COMPLIANCE
  1109. STATUS current
  1110. DESCRIPTION
  1111. "The compliance statement for SNMP entities which implement
  1112. this SCTP MIB Module.
  1113. There are a number of INDEX objects that cannot be represented
  1114. in the form of OBJECT clauses in SMIv2, but for which we have
  1115. the following compliance requirements, expressed in OBJECT
  1116. clause form in this description clause:
  1117. -- OBJECT sctpAssocLocalAddrType
  1118. -- SYNTAX InetAddressType {ipv4(1), ipv6(2)}
  1119. -- DESCRIPTION
  1120. -- It is only required to have IPv4 and IPv6 addresses without
  1121. -- zone indices.
  1122. -- The address with zone indices is required if an
  1123. -- implementation can connect multiple zones.
  1124. --
  1125. -- OBJECT sctpAssocLocalAddr
  1126. -- SYNTAX InetAddress (SIZE(4|16))
  1127. -- DESCRIPTION
  1128. -- An implementation is only required to support globally
  1129. -- unique IPv4 and IPv6 addresses.
  1130. --
  1131. -- OBJECT sctpAssocRemAddrType
  1132. -- SYNTAX InetAddressType {ipv4(1), ipv6(2)}
  1133. -- DESCRIPTION
  1134. -- It is only required to have IPv4 and IPv6 addresses without
  1135. -- zone indices.
  1136. -- The address with zone indices is required if an
  1137. -- implementation can connect multiple zones.
  1138. --
  1139. -- OBJECT sctpAssocRemAddr
  1140. -- SYNTAX InetAddress (SIZE(4|16))
  1141. -- DESCRIPTION
  1142. -- An implementation is only required to support globally
  1143. -- unique IPv4 and IPv6 addresses.
  1144. --
  1145. " -- closes DESCRIPTION clause of MODULE-COMPLIANCE
  1146. MODULE -- this module
  1147. MANDATORY-GROUPS { sctpLayerParamsGroup,
  1148. sctpPerAssocParamsGroup,
  1149. sctpStatsGroup,
  1150. sctpPerAssocStatsGroup
  1151. }
  1152. OBJECT sctpAssocRemPrimAddrType
  1153. SYNTAX InetAddressType { ipv4(1),
  1154. ipv6(2)
  1155. }
  1156. DESCRIPTION
  1157. "It is only required to have IPv4 and IPv6 addresses
  1158. without zone indices.
  1159. The address with zone indices is required if an
  1160. implementation can connect multiple zones."
  1161. OBJECT sctpAssocRemPrimAddr
  1162. SYNTAX InetAddress (SIZE(4|16))
  1163. DESCRIPTION
  1164. "An implementation is only required to support globally
  1165. unique IPv4 and globally unique IPv6 addresses."
  1166. OBJECT sctpAssocState
  1167. WRITE-SYNTAX INTEGER { deleteTCB(9) }
  1168. MIN-ACCESS read-only
  1169. DESCRIPTION
  1170. "Only the deleteTCB(9) value MAY be set by a management
  1171. station at most. A read-only option is also considered to
  1172. be compliant with this MIB module description."
  1173. GROUP sctpInverseGroup
  1174. DESCRIPTION
  1175. "Objects used in inverse lookup tables. This should be
  1176. implemented, at the discretion of the implementers, for
  1177. easier lookups in the association tables"
  1178. ::= { sctpMibCompliances 1 }
  1179. END