SNMP-PROXY-MIB.txt 8.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295
  1. SNMP-PROXY-MIB DEFINITIONS ::= BEGIN
  2. IMPORTS
  3. MODULE-IDENTITY,
  4. OBJECT-TYPE,
  5. snmpModules
  6. FROM SNMPv2-SMI
  7. RowStatus,
  8. StorageType
  9. FROM SNMPv2-TC
  10. SnmpEngineID,
  11. SnmpAdminString
  12. FROM SNMP-FRAMEWORK-MIB
  13. SnmpTagValue
  14. FROM SNMP-TARGET-MIB
  15. MODULE-COMPLIANCE,
  16. OBJECT-GROUP
  17. FROM SNMPv2-CONF;
  18. snmpProxyMIB MODULE-IDENTITY
  19. LAST-UPDATED "200210140000Z"
  20. ORGANIZATION "IETF SNMPv3 Working Group"
  21. CONTACT-INFO
  22. "WG-email: snmpv3@lists.tislabs.com
  23. Subscribe: majordomo@lists.tislabs.com
  24. In message body: subscribe snmpv3
  25. Co-Chair: Russ Mundy
  26. Network Associates Laboratories
  27. Postal: 15204 Omega Drive, Suite 300
  28. Rockville, MD 20850-4601
  29. USA
  30. EMail: mundy@tislabs.com
  31. Phone: +1 301-947-7107
  32. Co-Chair: David Harrington
  33. Enterasys Networks
  34. Postal: 35 Industrial Way
  35. P. O. Box 5004
  36. Rochester, New Hampshire 03866-5005
  37. USA
  38. EMail: dbh@enterasys.com
  39. Phone: +1 603-337-2614
  40. Co-editor: David B. Levi
  41. Nortel Networks
  42. Postal: 3505 Kesterwood Drive
  43. Knoxville, Tennessee 37918
  44. EMail: dlevi@nortelnetworks.com
  45. Phone: +1 865 686 0432
  46. Co-editor: Paul Meyer
  47. Secure Computing Corporation
  48. Postal: 2675 Long Lake Road
  49. Roseville, Minnesota 55113
  50. EMail: paul_meyer@securecomputing.com
  51. Phone: +1 651 628 1592
  52. Co-editor: Bob Stewart
  53. Retired"
  54. DESCRIPTION
  55. "This MIB module defines MIB objects which provide
  56. mechanisms to remotely configure the parameters
  57. used by a proxy forwarding application.
  58. Copyright (C) The Internet Society (2002). This
  59. version of this MIB module is part of RFC 3413;
  60. see the RFC itself for full legal notices.
  61. "
  62. REVISION "200210140000Z" -- 14 October 2002
  63. DESCRIPTION "Clarifications, published as
  64. RFC 3413."
  65. REVISION "199808040000Z" -- 4 August 1998
  66. DESCRIPTION "Clarifications, published as
  67. RFC 2573."
  68. REVISION "199707140000Z" -- 14 July 1997
  69. DESCRIPTION "The initial revision, published as RFC2273."
  70. ::= { snmpModules 14 }
  71. snmpProxyObjects OBJECT IDENTIFIER ::= { snmpProxyMIB 1 }
  72. snmpProxyConformance OBJECT IDENTIFIER ::= { snmpProxyMIB 3 }
  73. --
  74. --
  75. -- The snmpProxyObjects group
  76. --
  77. --
  78. snmpProxyTable OBJECT-TYPE
  79. SYNTAX SEQUENCE OF SnmpProxyEntry
  80. MAX-ACCESS not-accessible
  81. STATUS current
  82. DESCRIPTION
  83. "The table of translation parameters used by proxy forwarder
  84. applications for forwarding SNMP messages."
  85. ::= { snmpProxyObjects 2 }
  86. snmpProxyEntry OBJECT-TYPE
  87. SYNTAX SnmpProxyEntry
  88. MAX-ACCESS not-accessible
  89. STATUS current
  90. DESCRIPTION
  91. "A set of translation parameters used by a proxy forwarder
  92. application for forwarding SNMP messages.
  93. Entries in the snmpProxyTable are created and deleted
  94. using the snmpProxyRowStatus object."
  95. INDEX { IMPLIED snmpProxyName }
  96. ::= { snmpProxyTable 1 }
  97. SnmpProxyEntry ::= SEQUENCE {
  98. snmpProxyName SnmpAdminString,
  99. snmpProxyType INTEGER,
  100. snmpProxyContextEngineID SnmpEngineID,
  101. snmpProxyContextName SnmpAdminString,
  102. snmpProxyTargetParamsIn SnmpAdminString,
  103. snmpProxySingleTargetOut SnmpAdminString,
  104. snmpProxyMultipleTargetOut SnmpTagValue,
  105. snmpProxyStorageType StorageType,
  106. snmpProxyRowStatus RowStatus
  107. }
  108. snmpProxyName OBJECT-TYPE
  109. SYNTAX SnmpAdminString (SIZE(1..32))
  110. MAX-ACCESS not-accessible
  111. STATUS current
  112. DESCRIPTION
  113. "The locally arbitrary, but unique identifier associated
  114. with this snmpProxyEntry."
  115. ::= { snmpProxyEntry 1 }
  116. snmpProxyType OBJECT-TYPE
  117. SYNTAX INTEGER {
  118. read(1),
  119. write(2),
  120. trap(3),
  121. inform(4)
  122. }
  123. MAX-ACCESS read-create
  124. STATUS current
  125. DESCRIPTION
  126. "The type of message that may be forwarded using
  127. the translation parameters defined by this entry."
  128. ::= { snmpProxyEntry 2 }
  129. snmpProxyContextEngineID OBJECT-TYPE
  130. SYNTAX SnmpEngineID
  131. MAX-ACCESS read-create
  132. STATUS current
  133. DESCRIPTION
  134. "The contextEngineID contained in messages that
  135. may be forwarded using the translation parameters
  136. defined by this entry."
  137. ::= { snmpProxyEntry 3 }
  138. snmpProxyContextName OBJECT-TYPE
  139. SYNTAX SnmpAdminString
  140. MAX-ACCESS read-create
  141. STATUS current
  142. DESCRIPTION
  143. "The contextName contained in messages that may be
  144. forwarded using the translation parameters defined
  145. by this entry.
  146. This object is optional, and if not supported, the
  147. contextName contained in a message is ignored when
  148. selecting an entry in the snmpProxyTable."
  149. ::= { snmpProxyEntry 4 }
  150. snmpProxyTargetParamsIn OBJECT-TYPE
  151. SYNTAX SnmpAdminString
  152. MAX-ACCESS read-create
  153. STATUS current
  154. DESCRIPTION
  155. "This object selects an entry in the snmpTargetParamsTable.
  156. The selected entry is used to determine which row of the
  157. snmpProxyTable to use for forwarding received messages."
  158. ::= { snmpProxyEntry 5 }
  159. snmpProxySingleTargetOut OBJECT-TYPE
  160. SYNTAX SnmpAdminString
  161. MAX-ACCESS read-create
  162. STATUS current
  163. DESCRIPTION
  164. "This object selects a management target defined in the
  165. snmpTargetAddrTable (in the SNMP-TARGET-MIB). The
  166. selected target is defined by an entry in the
  167. snmpTargetAddrTable whose index value (snmpTargetAddrName)
  168. is equal to this object.
  169. This object is only used when selection of a single
  170. target is required (i.e. when forwarding an incoming
  171. read or write request)."
  172. ::= { snmpProxyEntry 6 }
  173. snmpProxyMultipleTargetOut OBJECT-TYPE
  174. SYNTAX SnmpTagValue
  175. MAX-ACCESS read-create
  176. STATUS current
  177. DESCRIPTION
  178. "This object selects a set of management targets defined
  179. in the snmpTargetAddrTable (in the SNMP-TARGET-MIB).
  180. This object is only used when selection of multiple
  181. targets is required (i.e. when forwarding an incoming
  182. notification)."
  183. ::= { snmpProxyEntry 7 }
  184. snmpProxyStorageType OBJECT-TYPE
  185. SYNTAX StorageType
  186. MAX-ACCESS read-create
  187. STATUS current
  188. DESCRIPTION
  189. "The storage type of this conceptual row.
  190. Conceptual rows having the value 'permanent' need not
  191. allow write-access to any columnar objects in the row."
  192. DEFVAL { nonVolatile }
  193. ::= { snmpProxyEntry 8 }
  194. snmpProxyRowStatus OBJECT-TYPE
  195. SYNTAX RowStatus
  196. MAX-ACCESS read-create
  197. STATUS current
  198. DESCRIPTION
  199. "The status of this conceptual row.
  200. To create a row in this table, a manager must
  201. set this object to either createAndGo(4) or
  202. createAndWait(5).
  203. The following objects may not be modified while the
  204. value of this object is active(1):
  205. - snmpProxyType
  206. - snmpProxyContextEngineID
  207. - snmpProxyContextName
  208. - snmpProxyTargetParamsIn
  209. - snmpProxySingleTargetOut
  210. - snmpProxyMultipleTargetOut"
  211. ::= { snmpProxyEntry 9 }
  212. --
  213. --
  214. -- Conformance information
  215. --
  216. --
  217. snmpProxyCompliances OBJECT IDENTIFIER ::=
  218. { snmpProxyConformance 1 }
  219. snmpProxyGroups OBJECT IDENTIFIER ::=
  220. { snmpProxyConformance 2 }
  221. --
  222. --
  223. -- Compliance statements
  224. --
  225. --
  226. snmpProxyCompliance MODULE-COMPLIANCE
  227. STATUS current
  228. DESCRIPTION
  229. "The compliance statement for SNMP entities which include
  230. a proxy forwarding application."
  231. MODULE SNMP-TARGET-MIB
  232. MANDATORY-GROUPS { snmpTargetBasicGroup,
  233. snmpTargetResponseGroup }
  234. MODULE -- This Module
  235. MANDATORY-GROUPS { snmpProxyGroup }
  236. ::= { snmpProxyCompliances 1 }
  237. snmpProxyGroup OBJECT-GROUP
  238. OBJECTS {
  239. snmpProxyType,
  240. snmpProxyContextEngineID,
  241. snmpProxyContextName,
  242. snmpProxyTargetParamsIn,
  243. snmpProxySingleTargetOut,
  244. snmpProxyMultipleTargetOut,
  245. snmpProxyStorageType,
  246. snmpProxyRowStatus
  247. }
  248. STATUS current
  249. DESCRIPTION
  250. "A collection of objects providing remote configuration of
  251. management target translation parameters for use by
  252. proxy forwarder applications."
  253. ::= { snmpProxyGroups 3 }
  254. END