SNMP-USM-AES-MIB.txt 2.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263
  1. SNMP-USM-AES-MIB DEFINITIONS ::= BEGIN
  2. IMPORTS
  3. MODULE-IDENTITY, OBJECT-IDENTITY,
  4. snmpModules FROM SNMPv2-SMI -- [RFC2578]
  5. snmpPrivProtocols FROM SNMP-FRAMEWORK-MIB; -- [RFC3411]
  6. snmpUsmAesMIB MODULE-IDENTITY
  7. LAST-UPDATED "200406140000Z"
  8. ORGANIZATION "IETF"
  9. CONTACT-INFO "Uri Blumenthal
  10. Lucent Technologies / Bell Labs
  11. 67 Whippany Rd.
  12. 14D-318
  13. Whippany, NJ 07981, USA
  14. 973-386-2163
  15. uri@bell-labs.com
  16. Fabio Maino
  17. Andiamo Systems, Inc.
  18. 375 East Tasman Drive
  19. San Jose, CA 95134, USA
  20. 408-853-7530
  21. fmaino@andiamo.com
  22. Keith McCloghrie
  23. Cisco Systems, Inc.
  24. 170 West Tasman Drive
  25. San Jose, CA 95134-1706, USA
  26. 408-526-5260
  27. kzm@cisco.com"
  28. DESCRIPTION "Definitions of Object Identities needed for
  29. the use of AES by SNMP's User-based Security
  30. Model.
  31. Copyright (C) The Internet Society (2004).
  32. This version of this MIB module is part of RFC 3826;
  33. see the RFC itself for full legal notices.
  34. Supplementary information may be available on
  35. http://www.ietf.org/copyrights/ianamib.html."
  36. REVISION "200406140000Z"
  37. DESCRIPTION "Initial version, published as RFC3826"
  38. ::= { snmpModules 20 }
  39. usmAesCfb128Protocol OBJECT-IDENTITY
  40. STATUS current
  41. DESCRIPTION "The CFB128-AES-128 Privacy Protocol."
  42. REFERENCE "- Specification for the ADVANCED ENCRYPTION
  43. STANDARD. Federal Information Processing
  44. Standard (FIPS) Publication 197.
  45. (November 2001).
  46. - Dworkin, M., NIST Recommendation for Block
  47. Cipher Modes of Operation, Methods and
  48. Techniques. NIST Special Publication 800-38A
  49. (December 2001).
  50. "
  51. ::= { snmpPrivProtocols 4 }
  52. END