UDP-MIB.txt 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550
  1. UDP-MIB DEFINITIONS ::= BEGIN
  2. IMPORTS
  3. MODULE-IDENTITY, OBJECT-TYPE, Integer32, Counter32, Counter64,
  4. Unsigned32, IpAddress, mib-2 FROM SNMPv2-SMI
  5. MODULE-COMPLIANCE, OBJECT-GROUP FROM SNMPv2-CONF
  6. InetAddress, InetAddressType,
  7. InetPortNumber FROM INET-ADDRESS-MIB;
  8. udpMIB MODULE-IDENTITY
  9. LAST-UPDATED "200505200000Z" -- May 20, 2005
  10. ORGANIZATION
  11. "IETF IPv6 Working Group
  12. http://www.ietf.org/html.charters/ipv6-charter.html"
  13. CONTACT-INFO
  14. "Bill Fenner (editor)
  15. AT&T Labs -- Research
  16. 75 Willow Rd.
  17. Menlo Park, CA 94025
  18. Phone: +1 650 330-7893
  19. Email: <fenner@research.att.com>
  20. John Flick (editor)
  21. Hewlett-Packard Company
  22. 8000 Foothills Blvd. M/S 5557
  23. Roseville, CA 95747
  24. Phone: +1 916 785 4018
  25. Email: <john.flick@hp.com>
  26. Send comments to <ipv6@ietf.org>"
  27. DESCRIPTION
  28. "The MIB module for managing UDP implementations.
  29. Copyright (C) The Internet Society (2005). This
  30. version of this MIB module is part of RFC 4113;
  31. see the RFC itself for full legal notices."
  32. REVISION "200505200000Z" -- May 20, 2005
  33. DESCRIPTION
  34. "IP version neutral revision, incorporating the
  35. following revisions:
  36. - Added udpHCInDatagrams and udpHCOutDatagrams in order
  37. to provide high-capacity counters for fast networks.
  38. - Added text to the descriptions of all counter objects
  39. to indicate how discontinuities are detected.
  40. - Deprecated the IPv4-specific udpTable and replaced it
  41. with the version neutral udpEndpointTable. This
  42. table includes support for connected UDP endpoints
  43. and support for identification of the operating
  44. system process associated with a UDP endpoint.
  45. - Deprecated the udpGroup and replaced it with object
  46. groups representing the current set of objects.
  47. - Deprecated udpMIBCompliance and replaced it with
  48. udpMIBCompliance2, which includes the compliance
  49. information for the new object groups.
  50. This version published as RFC 4113."
  51. REVISION "199411010000Z" -- November 1, 1994
  52. DESCRIPTION
  53. "Initial SMIv2 version, published as RFC 2013."
  54. REVISION "199103310000Z" -- March 31, 1991
  55. DESCRIPTION
  56. "The initial revision of this MIB module was part of
  57. MIB-II, published as RFC 1213."
  58. ::= { mib-2 50 }
  59. -- the UDP group
  60. udp OBJECT IDENTIFIER ::= { mib-2 7 }
  61. udpInDatagrams OBJECT-TYPE
  62. SYNTAX Counter32
  63. MAX-ACCESS read-only
  64. STATUS current
  65. DESCRIPTION
  66. "The total number of UDP datagrams delivered to UDP
  67. users.
  68. Discontinuities in the value of this counter can occur
  69. at re-initialization of the management system, and at
  70. other times as indicated by discontinuities in the
  71. value of sysUpTime."
  72. ::= { udp 1 }
  73. udpNoPorts OBJECT-TYPE
  74. SYNTAX Counter32
  75. MAX-ACCESS read-only
  76. STATUS current
  77. DESCRIPTION
  78. "The total number of received UDP datagrams for which
  79. there was no application at the destination port.
  80. Discontinuities in the value of this counter can occur
  81. at re-initialization of the management system, and at
  82. other times as indicated by discontinuities in the
  83. value of sysUpTime."
  84. ::= { udp 2 }
  85. udpInErrors OBJECT-TYPE
  86. SYNTAX Counter32
  87. MAX-ACCESS read-only
  88. STATUS current
  89. DESCRIPTION
  90. "The number of received UDP datagrams that could not be
  91. delivered for reasons other than the lack of an
  92. application at the destination port.
  93. Discontinuities in the value of this counter can occur
  94. at re-initialization of the management system, and at
  95. other times as indicated by discontinuities in the
  96. value of sysUpTime."
  97. ::= { udp 3 }
  98. udpOutDatagrams OBJECT-TYPE
  99. SYNTAX Counter32
  100. MAX-ACCESS read-only
  101. STATUS current
  102. DESCRIPTION
  103. "The total number of UDP datagrams sent from this
  104. entity.
  105. Discontinuities in the value of this counter can occur
  106. at re-initialization of the management system, and at
  107. other times as indicated by discontinuities in the
  108. value of sysUpTime."
  109. ::= { udp 4 }
  110. udpHCInDatagrams OBJECT-TYPE
  111. SYNTAX Counter64
  112. MAX-ACCESS read-only
  113. STATUS current
  114. DESCRIPTION
  115. "The total number of UDP datagrams delivered to UDP
  116. users, for devices that can receive more than 1
  117. million UDP datagrams per second.
  118. Discontinuities in the value of this counter can occur
  119. at re-initialization of the management system, and at
  120. other times as indicated by discontinuities in the
  121. value of sysUpTime."
  122. ::= { udp 8 }
  123. udpHCOutDatagrams OBJECT-TYPE
  124. SYNTAX Counter64
  125. MAX-ACCESS read-only
  126. STATUS current
  127. DESCRIPTION
  128. "The total number of UDP datagrams sent from this
  129. entity, for devices that can transmit more than 1
  130. million UDP datagrams per second.
  131. Discontinuities in the value of this counter can occur
  132. at re-initialization of the management system, and at
  133. other times as indicated by discontinuities in the
  134. value of sysUpTime."
  135. ::= { udp 9 }
  136. --
  137. -- { udp 6 } was defined as the ipv6UdpTable in RFC2454's
  138. -- IPV6-UDP-MIB. This RFC obsoletes RFC 2454, so { udp 6 } is
  139. -- obsoleted.
  140. --
  141. -- The UDP "Endpoint" table.
  142. udpEndpointTable OBJECT-TYPE
  143. SYNTAX SEQUENCE OF UdpEndpointEntry
  144. MAX-ACCESS not-accessible
  145. STATUS current
  146. DESCRIPTION
  147. "A table containing information about this entity's UDP
  148. endpoints on which a local application is currently
  149. accepting or sending datagrams.
  150. The address type in this table represents the address
  151. type used for the communication, irrespective of the
  152. higher-layer abstraction. For example, an application
  153. using IPv6 'sockets' to communicate via IPv4 between
  154. ::ffff:10.0.0.1 and ::ffff:10.0.0.2 would use
  155. InetAddressType ipv4(1).
  156. Unlike the udpTable in RFC 2013, this table also allows
  157. the representation of an application that completely
  158. specifies both local and remote addresses and ports. A
  159. listening application is represented in three possible
  160. ways:
  161. 1) An application that is willing to accept both IPv4
  162. and IPv6 datagrams is represented by a
  163. udpEndpointLocalAddressType of unknown(0) and a
  164. udpEndpointLocalAddress of ''h (a zero-length
  165. octet-string).
  166. 2) An application that is willing to accept only IPv4
  167. or only IPv6 datagrams is represented by a
  168. udpEndpointLocalAddressType of the appropriate
  169. address type and a udpEndpointLocalAddress of
  170. '0.0.0.0' or '::' respectively.
  171. 3) An application that is listening for datagrams only
  172. for a specific IP address but from any remote
  173. system is represented by a
  174. udpEndpointLocalAddressType of the appropriate
  175. address type, with udpEndpointLocalAddress
  176. specifying the local address.
  177. In all cases where the remote is a wildcard, the
  178. udpEndpointRemoteAddressType is unknown(0), the
  179. udpEndpointRemoteAddress is ''h (a zero-length
  180. octet-string), and the udpEndpointRemotePort is 0.
  181. If the operating system is demultiplexing UDP packets
  182. by remote address and port, or if the application has
  183. 'connected' the socket specifying a default remote
  184. address and port, the udpEndpointRemote* values should
  185. be used to reflect this."
  186. ::= { udp 7 }
  187. udpEndpointEntry OBJECT-TYPE
  188. SYNTAX UdpEndpointEntry
  189. MAX-ACCESS not-accessible
  190. STATUS current
  191. DESCRIPTION
  192. "Information about a particular current UDP endpoint.
  193. Implementers need to be aware that if the total number
  194. of elements (octets or sub-identifiers) in
  195. udpEndpointLocalAddress and udpEndpointRemoteAddress
  196. exceeds 111, then OIDs of column instances in this table
  197. will have more than 128 sub-identifiers and cannot be
  198. accessed using SNMPv1, SNMPv2c, or SNMPv3."
  199. INDEX { udpEndpointLocalAddressType,
  200. udpEndpointLocalAddress,
  201. udpEndpointLocalPort,
  202. udpEndpointRemoteAddressType,
  203. udpEndpointRemoteAddress,
  204. udpEndpointRemotePort,
  205. udpEndpointInstance }
  206. ::= { udpEndpointTable 1 }
  207. UdpEndpointEntry ::= SEQUENCE {
  208. udpEndpointLocalAddressType InetAddressType,
  209. udpEndpointLocalAddress InetAddress,
  210. udpEndpointLocalPort InetPortNumber,
  211. udpEndpointRemoteAddressType InetAddressType,
  212. udpEndpointRemoteAddress InetAddress,
  213. udpEndpointRemotePort InetPortNumber,
  214. udpEndpointInstance Unsigned32,
  215. udpEndpointProcess Unsigned32
  216. }
  217. udpEndpointLocalAddressType OBJECT-TYPE
  218. SYNTAX InetAddressType
  219. MAX-ACCESS not-accessible
  220. STATUS current
  221. DESCRIPTION
  222. "The address type of udpEndpointLocalAddress. Only
  223. IPv4, IPv4z, IPv6, and IPv6z addresses are expected, or
  224. unknown(0) if datagrams for all local IP addresses are
  225. accepted."
  226. ::= { udpEndpointEntry 1 }
  227. udpEndpointLocalAddress OBJECT-TYPE
  228. SYNTAX InetAddress
  229. MAX-ACCESS not-accessible
  230. STATUS current
  231. DESCRIPTION
  232. "The local IP address for this UDP endpoint.
  233. The value of this object can be represented in three
  234. possible ways, depending on the characteristics of the
  235. listening application:
  236. 1. For an application that is willing to accept both
  237. IPv4 and IPv6 datagrams, the value of this object
  238. must be ''h (a zero-length octet-string), with
  239. the value of the corresponding instance of the
  240. udpEndpointLocalAddressType object being unknown(0).
  241. 2. For an application that is willing to accept only IPv4
  242. or only IPv6 datagrams, the value of this object
  243. must be '0.0.0.0' or '::', respectively, while the
  244. corresponding instance of the
  245. udpEndpointLocalAddressType object represents the
  246. appropriate address type.
  247. 3. For an application that is listening for data
  248. destined only to a specific IP address, the value
  249. of this object is the specific IP address for which
  250. this node is receiving packets, with the
  251. corresponding instance of the
  252. udpEndpointLocalAddressType object representing the
  253. appropriate address type.
  254. As this object is used in the index for the
  255. udpEndpointTable, implementors of this table should be
  256. careful not to create entries that would result in OIDs
  257. with more than 128 subidentifiers; else the information
  258. cannot be accessed using SNMPv1, SNMPv2c, or SNMPv3."
  259. ::= { udpEndpointEntry 2 }
  260. udpEndpointLocalPort OBJECT-TYPE
  261. SYNTAX InetPortNumber
  262. MAX-ACCESS not-accessible
  263. STATUS current
  264. DESCRIPTION
  265. "The local port number for this UDP endpoint."
  266. ::= { udpEndpointEntry 3 }
  267. udpEndpointRemoteAddressType OBJECT-TYPE
  268. SYNTAX InetAddressType
  269. MAX-ACCESS not-accessible
  270. STATUS current
  271. DESCRIPTION
  272. "The address type of udpEndpointRemoteAddress. Only
  273. IPv4, IPv4z, IPv6, and IPv6z addresses are expected, or
  274. unknown(0) if datagrams for all remote IP addresses are
  275. accepted. Also, note that some combinations of
  276. udpEndpointLocalAdressType and
  277. udpEndpointRemoteAddressType are not supported. In
  278. particular, if the value of this object is not
  279. unknown(0), it is expected to always refer to the
  280. same IP version as udpEndpointLocalAddressType."
  281. ::= { udpEndpointEntry 4 }
  282. udpEndpointRemoteAddress OBJECT-TYPE
  283. SYNTAX InetAddress
  284. MAX-ACCESS not-accessible
  285. STATUS current
  286. DESCRIPTION
  287. "The remote IP address for this UDP endpoint. If
  288. datagrams from any remote system are to be accepted,
  289. this value is ''h (a zero-length octet-string).
  290. Otherwise, it has the type described by
  291. udpEndpointRemoteAddressType and is the address of the
  292. remote system from which datagrams are to be accepted
  293. (or to which all datagrams will be sent).
  294. As this object is used in the index for the
  295. udpEndpointTable, implementors of this table should be
  296. careful not to create entries that would result in OIDs
  297. with more than 128 subidentifiers; else the information
  298. cannot be accessed using SNMPv1, SNMPv2c, or SNMPv3."
  299. ::= { udpEndpointEntry 5 }
  300. udpEndpointRemotePort OBJECT-TYPE
  301. SYNTAX InetPortNumber
  302. MAX-ACCESS not-accessible
  303. STATUS current
  304. DESCRIPTION
  305. "The remote port number for this UDP endpoint. If
  306. datagrams from any remote system are to be accepted,
  307. this value is zero."
  308. ::= { udpEndpointEntry 6 }
  309. udpEndpointInstance OBJECT-TYPE
  310. SYNTAX Unsigned32 (1..'ffffffff'h)
  311. MAX-ACCESS not-accessible
  312. STATUS current
  313. DESCRIPTION
  314. "The instance of this tuple. This object is used to
  315. distinguish among multiple processes 'connected' to
  316. the same UDP endpoint. For example, on a system
  317. implementing the BSD sockets interface, this would be
  318. used to support the SO_REUSEADDR and SO_REUSEPORT
  319. socket options."
  320. ::= { udpEndpointEntry 7 }
  321. udpEndpointProcess OBJECT-TYPE
  322. SYNTAX Unsigned32
  323. MAX-ACCESS read-only
  324. STATUS current
  325. DESCRIPTION
  326. "The system's process ID for the process associated with
  327. this endpoint, or zero if there is no such process.
  328. This value is expected to be the same as
  329. HOST-RESOURCES-MIB::hrSWRunIndex or SYSAPPL-MIB::
  330. sysApplElmtRunIndex for some row in the appropriate
  331. tables."
  332. ::= { udpEndpointEntry 8 }
  333. -- The deprecated UDP Listener table
  334. -- The deprecated UDP listener table only contains information
  335. -- about this entity's IPv4 UDP end-points on which a local
  336. -- application is currently accepting datagrams. It does not
  337. -- provide more detailed connection information, or information
  338. -- about IPv6 endpoints.
  339. udpTable OBJECT-TYPE
  340. SYNTAX SEQUENCE OF UdpEntry
  341. MAX-ACCESS not-accessible
  342. STATUS deprecated
  343. DESCRIPTION
  344. "A table containing IPv4-specific UDP listener
  345. information. It contains information about all local
  346. IPv4 UDP end-points on which an application is
  347. currently accepting datagrams. This table has been
  348. deprecated in favor of the version neutral
  349. udpEndpointTable."
  350. ::= { udp 5 }
  351. udpEntry OBJECT-TYPE
  352. SYNTAX UdpEntry
  353. MAX-ACCESS not-accessible
  354. STATUS deprecated
  355. DESCRIPTION
  356. "Information about a particular current UDP listener."
  357. INDEX { udpLocalAddress, udpLocalPort }
  358. ::= { udpTable 1 }
  359. UdpEntry ::= SEQUENCE {
  360. udpLocalAddress IpAddress,
  361. udpLocalPort Integer32
  362. }
  363. udpLocalAddress OBJECT-TYPE
  364. SYNTAX IpAddress
  365. MAX-ACCESS read-only
  366. STATUS deprecated
  367. DESCRIPTION
  368. "The local IP address for this UDP listener. In the
  369. case of a UDP listener that is willing to accept
  370. datagrams for any IP interface associated with the
  371. node, the value 0.0.0.0 is used."
  372. ::= { udpEntry 1 }
  373. udpLocalPort OBJECT-TYPE
  374. SYNTAX Integer32 (0..65535)
  375. MAX-ACCESS read-only
  376. STATUS deprecated
  377. DESCRIPTION
  378. "The local port number for this UDP listener."
  379. ::= { udpEntry 2 }
  380. -- conformance information
  381. udpMIBConformance OBJECT IDENTIFIER ::= { udpMIB 2 }
  382. udpMIBCompliances OBJECT IDENTIFIER ::= { udpMIBConformance 1 }
  383. udpMIBGroups OBJECT IDENTIFIER ::= { udpMIBConformance 2 }
  384. -- compliance statements
  385. udpMIBCompliance2 MODULE-COMPLIANCE
  386. STATUS current
  387. DESCRIPTION
  388. "The compliance statement for systems that implement
  389. UDP.
  390. There are a number of INDEX objects that cannot be
  391. represented in the form of OBJECT clauses in SMIv2, but
  392. for which we have the following compliance
  393. requirements, expressed in OBJECT clause form in this
  394. description clause:
  395. -- OBJECT udpEndpointLocalAddressType
  396. -- SYNTAX InetAddressType { unknown(0), ipv4(1),
  397. -- ipv6(2), ipv4z(3),
  398. -- ipv6z(4) }
  399. -- DESCRIPTION
  400. -- Support for dns(5) is not required.
  401. -- OBJECT udpEndpointLocalAddress
  402. -- SYNTAX InetAddress (SIZE(0|4|8|16|20))
  403. -- DESCRIPTION
  404. -- Support is only required for zero-length
  405. -- octet-strings, and for scoped and unscoped
  406. -- IPv4 and IPv6 addresses.
  407. -- OBJECT udpEndpointRemoteAddressType
  408. -- SYNTAX InetAddressType { unknown(0), ipv4(1),
  409. -- ipv6(2), ipv4z(3),
  410. -- ipv6z(4) }
  411. -- DESCRIPTION
  412. -- Support for dns(5) is not required.
  413. -- OBJECT udpEndpointRemoteAddress
  414. -- SYNTAX InetAddress (SIZE(0|4|8|16|20))
  415. -- DESCRIPTION
  416. -- Support is only required for zero-length
  417. -- octet-strings, and for scoped and unscoped
  418. -- IPv4 and IPv6 addresses.
  419. "
  420. MODULE -- this module
  421. MANDATORY-GROUPS { udpBaseGroup, udpEndpointGroup }
  422. GROUP udpHCGroup
  423. DESCRIPTION
  424. "This group is mandatory for systems that
  425. are capable of receiving or transmitting more than
  426. 1 million UDP datagrams per second. 1 million
  427. datagrams per second will cause a Counter32 to
  428. wrap in just over an hour."
  429. ::= { udpMIBCompliances 2 }
  430. udpMIBCompliance MODULE-COMPLIANCE
  431. STATUS deprecated
  432. DESCRIPTION
  433. "The compliance statement for IPv4-only systems that
  434. implement UDP. For IP version independence, this
  435. compliance statement is deprecated in favor of
  436. udpMIBCompliance2. However, agents are still
  437. encouraged to implement these objects in order to
  438. interoperate with the deployed base of managers."
  439. MODULE -- this module
  440. MANDATORY-GROUPS { udpGroup }
  441. ::= { udpMIBCompliances 1 }
  442. -- units of conformance
  443. udpGroup OBJECT-GROUP
  444. OBJECTS { udpInDatagrams, udpNoPorts,
  445. udpInErrors, udpOutDatagrams,
  446. udpLocalAddress, udpLocalPort }
  447. STATUS deprecated
  448. DESCRIPTION
  449. "The deprecated group of objects providing for
  450. management of UDP over IPv4."
  451. ::= { udpMIBGroups 1 }
  452. udpBaseGroup OBJECT-GROUP
  453. OBJECTS { udpInDatagrams, udpNoPorts, udpInErrors,
  454. udpOutDatagrams }
  455. STATUS current
  456. DESCRIPTION
  457. "The group of objects providing for counters of UDP
  458. statistics."
  459. ::= { udpMIBGroups 2 }
  460. udpHCGroup OBJECT-GROUP
  461. OBJECTS { udpHCInDatagrams, udpHCOutDatagrams }
  462. STATUS current
  463. DESCRIPTION
  464. "The group of objects providing for counters of high
  465. speed UDP implementations."
  466. ::= { udpMIBGroups 3 }
  467. udpEndpointGroup OBJECT-GROUP
  468. OBJECTS { udpEndpointProcess }
  469. STATUS current
  470. DESCRIPTION
  471. "The group of objects providing for the IP version
  472. independent management of UDP 'endpoints'."
  473. ::= { udpMIBGroups 4 }
  474. END